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Lab - Mapping the Internet 

Objectives 
Part 1: Test Network Connectivity Using Ping 

Part 2: Trace a Route to a Remote Server Using Windows Tracert 

Part 3: Trace a Route to a Remote Server Using Web-Based and Software Tools 

Part 4: Compare Traceroute Results 

Background 
Route tracing computer software is a utility that lists the networks data has to traverse from the user's 
originating end device to a distant destination network. 

This network tool is typically executed at the command line as: 
tracert <destination network name or end device address> 

(Microsoft Windows systems) 

or 
traceroute <destination network name or end device address> 

(Unix and similar systems) 

Route tracing utilities allow a user to determine the path or routes as well as the delay across an IP network. 
Several tools exist to perform this function. 

The traceroute (or tracert) tool is often used for network troubleshooting. By showing a list of routers 
traversed, it allows the user to identify the path taken to reach a particular destination on the network or 
across internetworks. Each router represents a point where one network connects to another network and 
through which the data packet was forwarded. The number of routers is known as the number of "hops" the 
data traveled from source to destination. 

The displayed list can help identify data flow problems when trying to access a service such as a website. It 
can also be useful when performing tasks such as downloading data. If there are multiple websites (mirrors) 
available for the same data file, one can trace each mirror to get a good idea of which mirror would be the 
fastest to use. 

Two trace routes between the same source and destination conducted some time apart may produce different 
results. This is due to the "meshed" nature of the interconnected networks that comprise the Internet and the 
Internet Protocols ability to select different pathways over which to send packets. 

Command-line-based route tracing tools are usually embedded with the operating system of the end device. 

Other tools, such as VisualRoute™, are proprietary programs that provide extra information. VisualRoute 
uses available online information to graphically display the route. 

This lab assumes the installation of VisualRoute. If the computer you are using does not have VisualRoute 
installed, you can download the program using the following link: 

http://www.visualroute.com/download.html 

If you have any trouble downloading or installing VisualRoute, ask your instructor for assistance. Ensure that 
you download the Lite Edition. 

 

http://www.visualroute.com/download.html
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Scenario 
Using an Internet connection, you will use three route tracing utilities to examine the Internet pathway to 
destination networks. This activity should be performed on a computer that has Internet access and access to 
the command line. First, you will use the Windows embedded tracert utility. Second, you will use a web-based 
traceroute tool (http://www.subnetonline.com/pages/network-tools/online-traceroute.php). Finally, you will use 
the VisualRoute traceroute program. 

Required Resources 
1 PC (Windows 7, Vista, or XP with Internet access) 

Part 1: Test Network Connectivity Using Ping 

Step 1: Determine whether the remote server is reachable. 

To trace the route to a distant network, the PC used must have a working connection to the Internet. 

a. The first tool we will use is ping. Ping is a tool used to test whether a host is reachable. Packets of 
information are sent to the remote host with instructions to reply. Your local PC measures whether a 
response is received to each packet, and how long it takes for those packets to cross the network. The 
name ping comes from active sonar technology in which a pulse of sound is sent underwater and 
bounced off of terrain or other ships. 

b. From your PC, click the Windows Start icon, type cmd in the Search programs and files box, and then 
press Enter. 

 

c. At the command-line prompt, type ping www.cisco.com. 

 

d. The first output line displays the Fully Qualified Domain Name (FQDN) e144.dscb.akamaiedge.net. This 
is followed by the IP address 23.1.48.170. Cisco hosts the same web content on different servers 
throughout the world (known as mirrors). Therefore, depending upon where you are geographically, the 
FQDN and the IP address will be different. 

e. From this portion of the output: 

http://www.subnetonline.com/pages/network-tools/online-traceroute.php
http://www.cisco.com/
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Four pings were sent and a reply was received from each ping. Because each ping was responded to, 
there was 0% packet loss. On average, it took 54 ms (54 milliseconds) for the packets to cross the 
network. A millisecond is 1/1,000th of a second. 

Streaming video and online games are two applications that suffer when there is packet loss, or a slow 
network connection. A more accurate determination of an Internet connection speed can be determined 
by sending 100 pings, instead of the default 4. Here is how to do that: 

 

And here is what the output from that looks like: 

 

f. Now ping Regional Internet Registry (RIR) websites located in different parts of the world: 

For Africa: 
C:\> ping www.afrinic.net 

 

For Australia: 
C:\> ping www.apnic.net 
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For Europe: 
C:\> ping www.ripe.net 

 

For South America: 
C:\> ping www.lacnic.net 

 

All these pings were run from a computer located in the U.S. What happens to the average ping time in 
milliseconds when data is traveling within the same continent (North America) as compared to data from 
North America traveling to different continents? 

____________________________________________________________________________________ 

____________________________________________________________________________________ 

What is interesting about the pings that were sent to the European website? 

____________________________________________________________________________________ 

____________________________________________________________________________________ 



Lab - Mapping the Internet 

© 2016 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 5 of 10 

Part 2: Trace a Route to a Remote Server Using Tracert 

Step 1: Determine what route across the Internet traffic takes to the remote server. 

Now that basic reachability has been verified by using the ping tool, it is helpful to look more closely at each 
network segment that is crossed. To do this, the tracert tool will be used. 

a. At the command-line prompt, type tracert www.cisco.com. 

 

b. Save the tracert output in a text file as follows: 

1) Right-click the title bar of the Command Prompt window and choose Edit > Select All. 

2) Right-click the title bar of the Command Prompt window again and choose Edit > Copy. 

3) Open the Windows Notepad program: Windows Start icon > All Programs > Accessories > 
Notepad. 

4) To paste the output into Notepad, choose Edit > Paste. 

5) Choose File > Save As and save the Notepad file to your desktop as tracert1.txt. 

c. Run tracert for each destination website and save the output in sequentially numbered files. 

C:\> tracert www.afrinic.net 
C:\> tracert www.lacnic.net 

d. Interpreting tracert outputs. 

Routes traced can go through many hops and a number of different Internet Service Providers (ISPs), 
depending on the size of your ISP and the location of the source and destination hosts. Each “hop” 
represents a router. A router is a specialized type of computer used to direct traffic across the Internet. 
Imagine taking an automobile trip across several countries using many highways. At different points in the 
trip you come to a fork in the road in which you have the option to select from several different highways. 
Now further imagine that there is a device at each fork in the road that directs you to take the correct 
highway to your final destination. That is what a router does for packets on a network. 

Because computers talk in numbers, rather than words, routers are uniquely identified using IP addresses 
(numbers with the format x.x.x.x). The tracert tool shows you what path through the network a packet of 
information takes to reach its final destination. The tracert tool also gives you an idea of how fast traffic is 
going on each segment of the network. Three packets are sent to each router in the path, and the return 
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time is measured in milliseconds. Now use this information to analyze the tracert results to 
www.cisco.com. Below is the entire traceroute: 

 

Below is the breakdown: 

 

In the example output shown above, the tracert packets travel from the source PC to the local router 
default gateway (hop 1: 192.168.1.1) to the ISPs Point of Presence (POP) router (hop 2: 10.18.20.1). 
Every ISP has numerous POP routers. These POP routers are at the edge of the ISP’s network and are 
the means by which customers connect to the Internet. The packets travel along the Verizon network for 
two hops and then jump to a router that belongs to alter.net. This could mean that the packets have 
traveled to another ISP. This is significant because sometimes there is packet loss in the transition 
between ISPs, or sometimes one ISP is slower than another. How could we determine if alter.net is 
another ISP or the same ISP? 

e. There is an Internet tool known as whois. The whois tool allows us to determine who owns a domain 
name. A web-based whois tool is found at http://whois.domaintools.com/. This domain is also owned by 
Verizon according to the web-based whois tool. 

http://whois.domaintools.com/
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To summarize, Internet traffic starts at a home PC and travels through the home router (hop 1). It then 
connects to the ISP and travels through its network (hops 2-7) until it arrives at the remote server (hop 8). 
This is a relatively unusual example in which there is only one ISP involved from start to finish. It is typical 
to have two or more ISP involved as displayed in the following examples. 

f. Now examine an example that involves Internet traffic crossing multiple ISPs. Below is the tracert for 
www.afrinic.net: 

 

What happens at hop 7? Is level3.net the same ISP as hops 2-6, or a different ISP? Use the whois tool to 
answer this question. 
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____________________________________________________________________________________ 

What happens in hop 10 to the amount of time it takes for a packet to travel between Washington D.C. 
and Paris, as compared with the earlier hops 1-9? 

____________________________________________________________________________________ 

What happens in hop 18? Do a whois lookup on 168.209.201.74 using the whois tool. Who owns this 
network? 

____________________________________________________________________________________ 

g. Type tracert www.lacnic.net. 

 

What happens in hop 7? 

____________________________________________________________________________________ 

____________________________________________________________________________________ 

____________________________________________________________________________________ 

Part 3: Trace a Route to a Remote Server Using Web-Based and 
SoftwareTools 

Step 1: Use a web-based traceroute tool. 

a. Use http://www.subnetonline.com/pages/network-tools/online-tracepath.php to trace the route to the 
following websites: 

www.cisco.com 

www.afrinic.net 

Capture and save the output in Notepad. 

http://www.subnetonline.com/pages/network-tools/online-tracepath.php


Lab - Mapping the Internet 

© 2016 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 9 of 10 

How is the traceroute different when going to www.cisco.com from the command prompt (see Part 2) 
rather than from the online website? (Your results may vary depending upon where you are located 
geographically, and which ISP is providing connectivity to your school.) 

____________________________________________________________________________________ 

____________________________________________________________________________________ 

Compare the tracert from Part 1 that goes to Africa with the tracert that goes to Africa from the web 
interface. What difference do you notice? 

____________________________________________________________________________________ 

____________________________________________________________________________________ 

Some of the traceroutes have the abbreviation asymm in them. Any guesses as to what this means? 
What is its significance? 

____________________________________________________________________________________ 

____________________________________________________________________________________ 

Step 2: Use VisualRoute Lite Edition. 

VisualRoute is a proprietary traceroute program that can display the tracing path results graphically. 

a. Please download the VisualRoute Lite Edition from the following link if it is not already installed: 

http://www.visualroute.com/download.html 

If you have any trouble downloading or installing VisualRoute, ask your instructor for assistance. Ensure 
that you download the Lite Edition. 

b. Using VisualRoute 2010 Lite Edition, trace the routes to www.cisco.com. 

c. Record the IP addresses in the path in Notepad. 

 

http://www.visualroute.com/download.html
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Part 4: Compare Traceroute Results 

Compare the traceroute results to www.cisco.com from Parts 2 and 3. 

Step 1: List the path to www.cisco.com using tracert. 

_______________________________________________________________________________________ 

_______________________________________________________________________________________ 

Step 2: List the path to www.cisco.com using the web-based tool on subnetonline.com. 

_______________________________________________________________________________________ 

_______________________________________________________________________________________ 

Step 3: List the path to www.cisco.com using VisualRoute Lite edition. 

_______________________________________________________________________________________ 

_______________________________________________________________________________________ 

Did all the traceroute utilities use the same paths to www.cisco.com? Explain. 

_______________________________________________________________________________________ 

_______________________________________________________________________________________ 

Reflection 
Having now viewed traceroute through three different tools (tracert, web interface, and VisualRoute), are 
there any insights that using VisualRoute provided that the other two tools did not? 

_______________________________________________________________________________________ 

_______________________________________________________________________________________ 

_______________________________________________________________________________________ 
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