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These notes are designed for you to work through at your own pace.  

These notes do not explain every feature of the application therefore you are expected to 
make use of the Help facility. 

If you have any comments or queries, please contact: 

The ICT Skills tutor within your Learning Development Centre. 
Glasgow School for Business and Society – 0141 331 3300 
School of Health and Life Sciences – 0141 331 3456 
School of Engineering and Built Environment – 0141 273 1230 
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 Note: A basic knowledge of Excel is expected prior to beginning this booklet. This 
booklet is aimed at students who are already familiar with the contents of the MS Excel 
2016 booklet. 

When you have completed these notes you should be able to: 

 Sort and Filter Data 

 Parse Data 

 Use Functions and formula 

 IF 

 Countif 

 Look Up 

 Subtotals 

 Insert PivotTables 

When/If Things Go Wrong 

Before you start using Excel, remember that when/if an error occurs try the following to 
rectify the situation: 

To rectify problems such as a wrongly entered menu command: 

Use the Undo option by clicking on the Undo command  in the Quick Access Toolbar.  

To close a window/dialogue box: 

Click on the close command  at the top right-hand side of the window or dialogue box. 

If all else fails, exit from Excel (select the File tab and click on the Exit option) and start 
again. 

Using Help  

If there is a command or feature of Excel you would like to use but do not know how, use 
the help facility within the software. This provides instructions on using all features of the 
software. To use Help click on the Tell me what you want to do entry field, Figure 1:, in 
the middle of the ribbon. Some help options will be provided, or choose the Get Help 
option from the menu to type a phrase to search by in the search box.  

 

Figure 1: Tell me what you want to do text entry field 

  

Tell me what you want to do text entry field. 

Suggestions menu with Get Help option 
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Starting Excel and Entering Data 

Excel is opened from the Start menu (displayed on the Taskbar at the bottom of the 
screen). After clicking the Start button, select All Programs then Microsoft Office then 
Microsoft Office Excel 2016. This should open and display MS Excel options, choose the 
Blank workbook to open a blank worksheet ready for data to be entered, Figure 2. 

To enter data, select the appropriate cell (using the mouse or arrow keys), and type the 
data. Then press the ENTER    key, or any arrow key (to move to a cell in a new column or 

row), or click on the Enter icon   in the Formula Bar (which appears once you start 
typing in a cell). 

 

Figure 2: The Excel 2016 screen 

What is Data? 

Data is essentially information and can be either quantitative or qualitative.  

Qualitative or Categorical Data (Nominal, Ordinal) 

This data is non-numeric and can be gathered from questionnaires, interviews and 
written documentation. The two main types are: 

Nominal Data: The type of categorical data in which objects fall into unordered 
categories. Some examples are: gender, hair colour, smoking status and so on. 

Ordinal Data: The type of data in which the order is important. This data can be ranked or 
have a value in a scale. In a questionnaire you could be asked to rate your response from 
1 -5 with 1 being the lowest and 5 being the highest. 

Quick Access Toolbar The Ribbon Tabs 

Cell reference Formula 
Bar 

Column letter 

Active cell 

Row number Vertical Scroll 
bar 

Excel’s Minimise, Maximise 
and Close icons 

Help Functions 

Sheet reference Horizontal Scroll bar View icons Zoom slider 
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Quantitative Data (Discreet, Continuous)  

This data is numerical such as percentages or frequencies and can be measured and 
analysed statistically. The results are set of numbers. The two main types are: 

Discreet Data: This data has values which are distinct and separate. Discreet data could be 
the number of students in a class. 

Continuous Data: This data can be counted, ordered or measured. Continuous data could 
be your height, weight etc. 

 

Conditional Formatting 

In Excel data can be difficult to immediately understand. Conditional formatting allows 
you to apply formatting which will change the appearance of one or more cells or the 
data within a cell if it meets specified criteria. This will make the data stand out visually 
and enables patterns and trends to be identified. To apply conditional formatting select 
the cell or range of cells you wish to apply formatting to. Then from the Home tab select 
the Styles group and Conditional Formatting command. A Conditional Formatting drop-
down menu will be displayed with options for formatting, Figure 3. 

  Task 1 

Open Excel and enter the following data into a new spreadsheet: 

 

 

Adjust column widths if necessary. If you are unsure of how to do this, please refer to the 
Excel booklet. Save the spreadsheet as ICT Student Data. 
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Figure 3: Conditional Formatting menu  

From the drop-down menu choose the option you wish. For example, if the pass mark for 
the ICT Skills module was 32 out of 40 and we wished to see all pass marks in green and 
those below in red you can apply conditional formatting to do this. To apply conditional 
formatting for the pass marks, select the cells in the Mark column. Click the Conditional 
Formatting command and a drop-down menu will appear. Choose the Highlight Cells 
Rules option, a further menu will appear, choose the Between option. The Between 
dialogue box will be displayed. Type the values in the fields and choose the conditional 
formatting you wish to apply. If you do not see the colours you wish choose Custom 
Format… from the drop-down menu. Click OK. Then apply conditional formatting to the 
cells so that any cells containing a value below 32 appear in red. 

 Note: To remove or modify a conditional formatting select the data which has 
conditional formatting applied and from the Home tab, Styles group, click on the 
Conditional Formatting command. From the drop-down menu choose Manage Rules…. 
The Conditional Formatting Manage Rules dialogue box will be displayed showing all the 
rules applied to the data and you can choose to modify or remove any of the rules. 

 

Sorting data 

Data in rows or columns can be sorted either alphabetically or numerically, in ascending 
or descending order. To sort data, select all cells that contain the data to be sorted (not 
just the column or the row data has to be ordered by), then from the Data tab, Sort & 
Filter group click on the Sort command, Figure 4.  

Conditional Formatting 
command, drop down 
menu and further options. 

  Task 2 

Apply conditional formatting to the Pass column to show the text orange if a student 
has passed and blue if they have failed. 
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Figure 4: Sort & Filter group in the Data tab. Figure 5: Sort dialogue box. 

The Sort dialogue box will be displayed. You can specify whether or not the data you have 
selected has a header row by checking the option,  Figure 5 above. Choose a Column 
heading to Sort by from the Sort by drop-down menu; then Sort on criteria from that 
menu and then the sort Order from the respective drop-down menus. When you are 
happy with the options selected, click OK to perform the sort.  

 Note: When performing a sort, you must select all data to be sorted, e.g. select 
numbers and formulae as well as labels if sorting alphabetically – for example if you have 
student information in various columns, but wish to sort by Matric No you need to ensure 
that all columns are highlighted, not just Column A. This way the correct details will 
remain with the correct student. 

 Note: Remember if the data has not been sorted correctly, you can use the Undo 
option to get the data back to its original form and try again.  

 

Filtering Data 

When working in Excel you can choose to filter data to create a data subset which 
displays only information which meets specified criteria, other data will be hidden. You 
can filter by text, number, date, etc. For example, if you wished to show only students 
who had passed the ICT Skills module you could filter this information into a subset. After 
data has been filtered it can be copied, edited, charted etc. There are two main tools 
available for filtering data these are, the Filter Command and the Custom AutoFilter. 

The Filter Command 

Select a cell and then from the Data tab select the Filter command from the Sort and 
Filter group, Figure 6.  

 

Figure 6: The Sort & Filter group and the Filter command 

Filter arrows  will appear at the top of the columns. Choose which column you wish to 
filter by and click the Filter arrow. A drop-down menu will be displayed giving all of the 

  Task 3 

Sort the data alphabetically by Course Code. Re-save the ICT Student Data 
spreadsheet. 

Header Row 
Selector 

Column drop 
down list 



Excel Advanced 

Page 8                                                                                            

sorting and filtering options (see Figure 7 below). The sorting options are at the top of the 
drop-down menu and the filtering ones are at the bottom. By default, all of the options in 
the filtering section will be selected, that is they will have a tick in the check box. To 
choose your own filter criteria, remove the default settings by clicking on the Select All 
check box at the top. All of the ticks will be removed from the check boxes. Then choose 
the criteria you wish to filter by. You could, for example, choose to display only those 
students who are in level one.  

 Note: You can also filter by using the Sort and Filter command in the Editing group 
of the Home tab. 

 

Figure 7: Filter arrows 

 

Using the Custom AutoFilter 

You can also specify or customise the values you wish to filter by. To do this, select a cell 
in your workbook, then from the Data tab, Sort and Filter group choose the Filter 
command. The Filter arrows  will appear in the column headings. Choose the column 
heading that you wish to filter by and click on the Filter arrow. The drop-down menu will 
be displayed. If you choose a column that contains text you will be given options to 
custom filter by text, if you choose a column that contains numbers or dates you will be 
given other specific options. In the drop-down menu you will see Text/Number or Date 
filter options with right facing arrows. Rest the mouse on these arrows and a sub-menu 
appears with further options for setting the options of your filter. If one of the options in 
this menu is the criteria you are looking for then click on it. For example, you may choose 
to filter by a number higher or lower than one of the entries. If none of them are suitable 
choose the Custom Filter option at the bottom to customise the filter.  

The Custom AutoFilter dialogue box will open with options to customise your filter, see 
Figure 8. The title of the field you have chosen will be showing with fields to customise 
the filter. From the drop-down menus you can choose criteria and values from the table 
or enter your own values.  

 
Filter Arrows 

Drop Down menu with 
options 

Filtering options and 
the Select All option 

  Task 4 

Filter the data to show a subset containing only students who have passed the ICT 
Skills module. Restore it again to see all students. 
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Figure 8: The Custom AutoFilter dialogue box. 

 Note: You can customise your filters by using the comparison operators outlined 
below: 

Comparison Operators 

Operator Meaning 
= Equals to 
< Less than 
> Greater than 
<= Less than or equals to 
>= Greater than or equals to 
<> Exactly equal to 
AND Both values must be true 
OR Either value can be true 
Wildcard Operators Use 
? Any single character e.g. t?n returns tin; ten; ton 
* Any number of characters eg* 
~ Use before the another wildcard character to find the actual character 

in the data 

To remove filters click on the Filter command in the ribbon, the data will be restored. 

 

 Task 5 

Remove any filters already present.  

Filter the data to show only students who have passed the ICT Skills module with a 
mark between 34 and 40. Remove the filters. 
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Parsing Data 

Parsing Data is basically separating it to put each part in a separate column. Parsing data 
splits, the data in one column of an Excel spreadsheet and assign each segment to a 
separate column. For example, if you copy address data from Word into Excel and the 
address is all in one column, you can parse the data and split it into smaller parts. This 
would enable you for example to have the street name in one column, the town, the 
postcode and so on in others. Parsing data in this way allows you to split the data into 
more meaningful parts for analysis.  

To parse data, open your spreadsheet if it is not already open. Create a new column(s) 
that will contain the data after it is parsed. Highlight the column which contains the data 
to be parsed. Click on the Data tab and from the Data Tools group choose the Text to 
Columns command, Figure 9.  

 

Figure 9: Data Tools group with Text to Columns command 

The Convert Text to Columns Wizard – Step 1 of 3 will open.  

 

Figure 10: The Text to Columns Wizard dialogue box 

Step 1: The Wizard will tell you if it has identified a delimiter for the data. A delimiter is a 

data separator. Common delimiters are * (a star); , (a comma); ; (a semi-colon); : (colon) 

etc. You will be given a preview of your data, click on Next.  

Step 2: You will then identify the delimiter, by checking the appropriate box (that is put a 
tick √ in it). The Data Preview section will show you where the separation will take place. 
Click Next. 

Step 3: You can then set the Data format for your information. Choose the appropriate 
data type. 

Step 4: Click Finish. Your data will be entered in the current and the new column(s) 
created for it. If you have not created enough columns to fit the data a warning dialogue 
box will be displayed stating “Do you want to replace the contents of the destination 
cells?”. 
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 Note: If you click OK and there are not enough columns the data in the 
corresponding cells will be overwritten. 

 

Functions and Formula 

The real power of Excel is in being able to enter formulae to perform calculations on 
numeric data. A formula is a mathematical equation used to calculate a value and Excel 
has integrated functions which automate formulae creation. For example you could enter 
a formula to add cell contents in the following format =A1+A2+A3 or you can use the 
integrated SUM function which will insert the formula =SUM(A1:A3). There is an 
extensive list of formulae functions within the Formulas tab, Figure 11.  

 

Figure 11: The Formulas tab, Function Library group 

In order to use Excel you should have a basic knowledge of how formulae are written, this 
will help you to avoid problems when using formula.  

Formulae always start with an ‘=’ sign. This is to distinguish a formula from ordinary text. 
Some examples of formulae are: 

= D2+C2 (addition)  =B3*B4 (multiplication) =B4/A3 (division) 
=C6-D10 (subtraction) =B9*10% (10% of cell B9) =(B3*B4)/D10  

 Note: If there is more than one mathematical operator present, operator 
precedent rules will apply. When a formula is entered, the result of the calculation is 
displayed in the cell. The actual formula can be seen in the Formula Bar at the top of the 
spreadsheet. 

Cell Referencing 

As a rule, cell references should be used when entering formulae so that if you change 
the contents of a cell, the result of the formula will automatically change. A cell reference 
is the location of a cell or group of cells in a spreadsheet and consists of the column letter 
and row number for example A1, (Column A; Row 1). The column letter is always listed 
first. Cell references identify individual cells, or cell ranges in a worksheet. When entering 

  Task 6 

Make sure the data is not filtered. Parse the Name data in the spreadsheet to ensure 
that First Name and Surname are in two separate columns.  

Name the new column First Name, rename the column next to it Surname 



Excel Advanced 

Page 12                                                                                            

a cell reference you can either type the cell reference in, or you can click on the cell, (this 
reduces the possibility of errors). There are three main types of cell reference: 

1. Relative cell referencing – By default cell references are relative. This means that 
when a formula that contains relative referencing is copied, the pasted formula will 
have a cell reference that will change from row to row (or column to column). 

2. Absolute cell referencing – An absolute cell reference is fixed. Absolute references 
do not change they always refer to the same cell even if you copy a formula from one 
cell to another. Absolute references have $ signs, e.g. $D$9. When this is copied from 
row to row the absolute cell reference will remain the same. You would use this if 
you have a value from a cell which does not change. By default cell references are 
relative if you wish to change them to absolute you will have to add the $ sign. 

3. Mixed cell referencing - A mixed cell reference has either an absolute column and a 
relative row, or an absolute row and a relative column. $A1 is an example of a mixed 
reference where the column will not change but the row number will.  

Sum Function/Formula 

The SUM formula as mentioned earlier can be used to add the content of cells in either 
columns or rows. To use the SUM formula, move the cursor to the cell which will contain 
the result of the addition then type in the formula, for example =A1+B1+C1. This formula 
would add together the contents of cell A1, B1 and C1 and return the answer in the 
designated cell. To use the SUM function within Excel, choose the cell which will contain 

the results of the addition and click on the AutoSum command  from the Formulas tab, 
Function Library group, see Figure 11. Excel will suggest which cells have to be added 
together by showing the selection in a broken line and entering the formula in the cell. If 
the suggestion is correct press ENTER   . If not, type in the correct range of cells 
separated by a colon, e.g. A5:A10 or B10:F10, or highlight the range using the mouse. The 
SUM function will be displayed as =SUM(A5:A10). 

Average Function/Formula 

When working with data you may also wish to find out the average number in a data set. 
For example it may be useful to find out the average mark scored by students who have 
undertaken the ICT Skills module. To do this you can either type the formula in the cell 
you wish to contain the answer, or you can use the AVERAGE function. To do this, click in 
the cell where you want the answer to be displayed. Then click on the Formulas tab, 

Function Library group, More Functions command . A drop-down menu will appear 
offering options. Average is a statistical calculation, therefore choose Statistical from the 
options and a further drop-down menu will appear with the statistical options showing, 
Figure 12. Click on Average.  
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Figure 12: The More Functions command and sub-menus 

The Function Arguments dialogue box will appear, Excel may enter a data range and if it 
is correct, click OK, if not enter the correct data range and then click OK. The result will be 
displayed in the chosen cell.  

 

Figure 13: The Function Arguments dialogue box 

 

Conditional (Logical) Function/Formula 

These are formula which use the IF; AND; OR; NOT operators to test whether a condition 
is true or false.  

 IF: returns one value if the condition is true and another if it is false 

 AND: If all of the conditions are true then TRUE will be returned. If one or more of 
the conditions are false then FALSE will be returned. 

 OR: If any of the conditions are true then TRUE will be returned. 

 NOT: If the condition is true NOT returns FALSE; If the condition is false NOT 
returns TRUE. 

Once the true or false condition is determined a corresponding value will be returned. For 
example if you wanted to check if a student had scored enough to pass a module you 
could use a conditional formula to compare the value in the cell with the pass mark. If the 
mark is equal to or above the pass mark then you could display the value you wish to 
return for that (PASS), if it is false you could display another value (FAIL). 

The data range will be entered or 
displayed in this field. 

  Task 7 

Use the Average function to calculate the Average mark of students on the ICT Skills 
module. Enter the results in cell B32 and the label Average Mark in B31. 
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You can structure a conditional formula in a number of ways by using the operators listed 
above. One of the most common conditional formulae is the IF formula. 

IF  

The IF formula is used within Excel to test whether the contents of a cell meet certain 
criteria specified by you, and then return a value on that basis. This formula has three 
main parts: 

1. LOGICAL_ TEST: This is what the formula is using to decide which value to return 

2. VALUE_ IF_ TRUE: This value will be returned if the condition is met (is TRUE) 

3. VALUE_ IF_ FALSE: This value will be returned if the condition is not met (is FALSE) 

An IF formula therefore would consist of the following: 

=IF(logical_test, value_if_true, value_if_false) 

For example, a pass for students undertaking the ICT Skills assessment is 32.  
A conditional formula displaying Pass and Fail text in our spreadsheet would look like: 

 

You could also have more complex IF formula, for example if students undertaking an 
assessment were graded according to their mark, perhaps over 80 would be an A, over 65 
a B, over 50 a C and below 50 a Fail. This would be written like this: 

=IF(B2>=80,”A”,if(B2>=65,”B”,if(B2>=50,”C”,”FAIL”))) 

To enter an IF formula, click on the cell you would like the results of the IF formula to 
appear. Then type the formula, you will notice as you type the =if, that the functionality 
within Excel will try and predict the formula you are using and offer you the option of 
using the functions within Excel. A description of the different options will appear in a 
blue band across the screen. You can choose to use the options suggested or just 
continue typing in at this point. 

 

COUNTIF 

The COUNTIF formula is used within Excel to count cells within a data range which meets 
set criteria using conditional logic. For example, we may wish to know how many students 
have failed the ICT Skills assessment. A COUNTIF formula has two main parts. 

=IF(B2<32,”Fail”,”Pass”) 

logical_test value_if_true value_if_false 

  Task 8 

In cell K1 type the word Grade, and then in cell K2 construct an IF formula that will 
grade the ICT Skills assessment marks returning A for 38 and above, B for 34 and 
above, C for 32 or above and Fail for anything else.   

Once the result is displayed in cell K2, copy the formula down the column to return all 
grades. 
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1. RANGE: the data range of the cells you wish to count, for example A1:K7  

2. CRITERIA: for example ,”Fail” – this will count all cells which have the value “Fail” 
in them 

A COUNTIF formula would consist of the following: 

=COUNTIF(Range, Criteria) 
 A formula used to count the number of students who failed could then be shown as: 

 

Wildcard characters can also be used, two of the most common wildcard characters are: 

? – this will return any single character  

* - this will return a sequence of characters. 

To use COUNTIF, place the cursor in the cell in which you wish the results to show and 
type in the formula. Alternately click on the Formulas tab, Function Library group and 
More Functions command. A drop-down menu with options will appear. COUNTIF is a 
statistical function so click on this option. A further drop-down menu appears, choose the 
COUNTIF function, Figure 14.  

 

Figure 14: More Functions Command, with drop-down menus 

The Function Arguments dialogue box will appear as shown in Figure 15 below.  

=COUNTIF(K2:K7,”Fail”) 

Data Range Criteria 



Excel Advanced 

Page 16                                                                                            

 
Figure 15: The Function Arguments dialogue box.  

Enter the data range in the Range field, this will be in the format A1:B7 and the criteria of 
the cells you wish to count in the Criteria field. This can be a number, a range of numbers 
or letter(s) or wildcard characters. Then click on OK. The count should now appear in the 
cell selected by you.  

 

LOOK UP Function 

You can use Excel to “look up” and then return a value in a list or in a table. After the 
value has been looked up it can be used for calculations. This can be useful to ensure the 
accuracy and validity of information and eliminate data entry errors. There are different 
ways of looking up values in a list and displaying the results. The two most popular 
functions are, the VLOOKUP where the V stands for vertical and HLOOKUP where the H 
stands for horizontal. Both work in much the same way therefore just the VLOOKUP 
function will be described. 

Vertical LOOKUP (VLOOKUP)  

The VLOOKUP formula, searches the values in the vertical columns of a list or table for a 
specified value, column by column from the left side. This data is then copied and can be 
returned elsewhere in the worksheet/book. There are four basic arguments in this 
function: 

=VLOOKUP(lookup_value,table_array,col_index_num,[range_lookup]) 

1. LOOK UP VALUE: Identifies the value to be looked up, this could be a number, a 
string of text or an actual cell reference. In the lookup_value section enter the 
value that you wish to look up. You can do this by either clicking on the cell which 
contains the value, or typing the value in. 

2. THE TABLE ARRAY: The cell range containing the data. This is normally in the 
format A1:D10, it is recommended that when you use a cell range that you make 
the cell references absolute by inserting the $ sign in front of them (see the 
description on p 12). 

3. THE COL_INDEX_NUM: An index number to identify the column (or the row in 
case of HLOOKUP) from which the value will come. This is the column within the 
table which contains the data you are looking for. 

  Task 9 

In cell B33 on the spreadsheet create a COUNTIF formula which will count the number 
of students from the BAAC course code who have undertaken the ICT Skills 
Assessment. Label it BAAC student count in cell A33. 
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4. THE RANGE LOOKUP: This is a non compulsory option. A range lookup specifies 
whether there is an exact match or an approximate match for the search. If you 
wish an EXACT match you must put FALSE in this section. If you wish an 
APPROXIMATE match to be found (the largest value that is less than the 
lookup_value) then TRUE should be entered. 

To look up a value you must firstly click in the destination cell. That is the cell in which you 
wish the result of your lookup to be displayed. Then from the Formula tab choose the 
Lookup and Reference command. When you click on this a drop-down list displaying the 
various functions will show. Choose the VLOOKUP option, Figure 16.  

 

Figure 16: the Lookup and Reference command and drop-down menu 

The Function Arguments dialogue box will be displayed, Figure 17. Enter the function 
arguments as required. Then click on OK. 

 

Figure 17: Function Arguments dialogue box 

For example, from the table we have currently created you could use a VLOOKUP function 
and look up the Matric no of a student from the table and return their course code. To do 
this you would: 

1. Open your workbook if it is not already open. 

2. Type the label(s) for your lookup. In this case it would be: 

a. Enter a Matric no (cell A9) 

b. Course Code (cell A10) 

3. Use the VLOOKUP function in the destination cell (B10) and enter all of the 
arguments. Press Enter or click OK 
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The formula you would enter in cell B10 would be: 

=VLOOKUP(B9,A1:K7,4,FALSE) 

Or the arguments you would enter in the Function Arguments dialogue box would be: 

 Lookup_ value: B9 (Excel will go to cell B9 for the value entered there) 

 Table_array: A1:K7, (the cell range of the table) 

 Col_index_num: 4 (the column number which contains the data you would like 
returned) 

 Range_lookup: False (an exact match for your lookup value must be found. For 
this particular example we would require an exact match, for many others an 
approximate would be required)  

 Note: You will receive #N/A answer in your cell until you enter a matriculation 
number in cell B9. 

 

VLOOKUP Errors 

If you find once you have entered your formula that you have an error indication in your 
returns (#N/A) check the validity of the data you have entered. Common reasons for 
error messages are: 

Exact and approximate values. If you specify that you wish the function to return an 
exact value and that exact value does not exist this may then lead to an error.  

Missing Data: If you use a value that does not exist then you will be given an error 
message. When the formula searched the table for the value it was missing, an error 
message was then generated. 

Unsorted Data: When you use a VLOOKUP function the value will be looked up from a 
sorted list, if the list is not sorted this may cause an error message to be generated. 

Custom/worksheet function used that is not available: If you have created the lookup 
formula using a customised function it may not be available on all versions of the 
application. If you then use another computer which does not have the updated 
functionality you may not be able to access it. 

SUBTOTALS  

The subtotal function enables you to calculate Subtotals and Grand totals for data in your 
spreadsheet. The subtotals you create will summarise your data by for example average 
or sum of the data range. A full list of summary subtotal functions is listed in the table 
below.  

  Task 10 

Type the labels, Enter a Matric No in cell A34 (the matriculation number would be 
entered in B34, and Phone No in A35 (the phone number would be displayed in B35. 

Using a VLOOKUP formula or function, search the workbook by matriculation number 
to return the phone number for students. 
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 Note: If you filter data that contains subtotals they may appear hidden. 
 

Function Use 

AVERAGE Calculates the arithmetic mean of a group. 

COUNT Counts the number of entries in a group. 

MAX Returns the maximum value in a group. 

MIN Returns the minimum value in a group. 

PRODUCT Multiplies values in a group. 

STDDEV Estimates standard deviation of the samples of a group. 

STDDEVP Calculates standard deviation of a group. 

SUM Calculated the sum of the values in a group. 

VAR Estimates the variance of the samples of a group. 

VARP Calculates the variance of a group. 

To add subtotals click on a cell within the spreadsheet. Then from the Data tab, Outline 
group click on the Subtotal command, Figure 18.  

 

Figure 18: The Outline group within the Data tab 

The subtotal dialogue box will be displayed, Figure 19, with subtotal options.  

 

Figure 19: The Subtotal dialogue box. 

Depending on your subtotal criteria choose where your subtotals will be inserted from 
the At each change in: drop down menu. This will be one of the column headings. Next 
choose which summary function you would like from the Use function: drop down menu. 
A full list of the functions and their use is shown in the table on the previous page.   Then 
choose the column you would like to add the subtotal to from the Add the subtotal to: 
list by checking the box next to the column name.  

You also have the option to choose to replace current subtotals, insert page breaks 
between subtotals and to include a summary below the data. If you do not tick the 

Subtotal command 
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Summary below data option check box, you will not see a grand total in your 
spreadsheet. 

Once you have chosen all options click on the OK button. 

To remove a subtotal, click on the Subtotal command, when the Subtotal dialogue box 
opens click on the Remove All button. 

 

Pivot Tables 

PivotTables are used in Excel to summarise data and present the information in report 
format. PivotTable reports allow large volumes of data to be split into small concise 
reports. When creating a PivotTable report it is important to remember that each column 
heading in your workbook will become a field name in the report. Column headings must 
therefore be appropriate. Also when creating a PivotTable report it is best to ensure your 
data has no blank columns or rows. 

To create a PivotTable report, click in a cell in your spreadsheet, then from the Insert tab, 
Tables group click on the top half of the PivotTable command, Figure 20. If you click at the 
bottom half choose PivotTable from the menu that will appear.  

 

Figure 20: Table group and PivotTable command 

The Create PivotTable dialogue box will open, the data source chosen earlier will be 
showing in the Select a table or range, Table/Range field. Choose where the PivotTable 
report should be displayed within the workbook with the default option being in a New 
Worksheet, Figure 21.  

   Task 11 

Create subtotals for students who have passed the ICT Skills module. Display the mark 
by Course Code. 

Save and close the spreadsheet. 
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Figure 21: Create PivotTable dialogue box 
Click OK. Your PivotTable report layout will be created and look like 

 

Figure 22 below. 

 

 

Figure 22: PivotTable Report worksheet 

The PivotTable Report layout will be displayed in the left hand side of the worksheet and 
the Pivot Table Field List pane will have opened at the right hand side. Select the fields 
you wish to add to your report by checking the box next to the field name in the Pivot 
Table Field List pane. You should notice the data appearing in your PivotTable. Excel will 

Select a table or range 

Where will the PivotTable 
report be placed. 

PivotTable Tools Tab 

PivotTable Fields List: This 
will contain the fields from 
the data source. You must 
check the boxes to include 
them in the PivotTable 
Report 

Report Filter: The data 
value you wish to filter your 
report by. 

PivotTable Tools Tab 

PivotTable Fields List: This 
will contain the fields from 
the data source. You must 
check the boxes to include 
them in the PivotTable 
Report 

Report Filter: The data 
value you wish to filter your 
report by. 
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automatically assign the value(s) to the four smaller areas below the PivotTable Field List 
pane. If, however, you wish them to be in another area you can change the area by 
dragging and dropping the value to the area you wish. Alternately, click on the value that 
you wish to move and a menu will appear for you to choose the option you wish. 

 Note: The data in the PivotTable will change as you move the values around. 

The fields you add to your PivotTable will depend on what you would like to report on. 
For example, if you would like to know the number of students from each course you 
would add the Course Code and Student Nos fields to the PivotTable.  

 

You can also add fields to your report to expand on it, you could perhaps create a 
PivotTable report which shows the average mark of the students on each programme and 
the average overall mark. To do this add the Programme Code and Mark fields to your 
PivotTable Report. Excel will assign them to the areas and add them to the PivotTable. By 

default the Value is SUM (∑), however you can choose another value for the field. To do 
this click on the field name, a pop up menu will be displayed, Figure 23.  

 

Figure 23: Values pop up menu 

Choose Value Field Settings… from this menu and the Value Field Settings dialogue box 
will be displayed, Figure 24. 

  Task 12 

Remove the subtotal. 

Create a PivotTable Report showing the Marks by Course Code 
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Figure 24: Value Field Settings dialogue box 

Excel will insert a custom name for the value, if you do not wish this name change it to 
the one you wish. Then choose which calculation type you would like from the menu at 
the bottom and click OK. The calculation will be performed on your chosen field. 

 

If the data you have is large you may not be able to see all of the entries. To enable you to 
see the entries more clearly you can Pivot the information. To pivot the information you 
move the information from the Rows area at the bottom of the Pivot Field List pane to 
the Columns. This changes the layout of the information.  

 

  Task 13 

Change your PivotTable report to show the average marks for each programme. 

  Task 14 

Pivot the table to show Courses in the columns. 

Save and close the spreadsheets. 


